Viewing Pdfs in and Experience app offline

Comments

4 comments

  • Avatar
    Cedric Lemaire

    Hi Jeff,

    Thanks for reaching out and adding the detailed steps of what you're trying to accomplish.

    Just a few days ago, we added a tutorial that describes in general what you're looking for. More specifically, this part might help you to succeed. The example code in the ShowpadLib.getAssetsByTags and ShowpadLib.getAssetPreviewUrl sections can give you an idea on how to continue building your app.

    Using the code provided in the tutorial, we also tested the asset viewer. By closing the asset, we went back to our application and didn't need to exit the application.

    Let us know if this gave you more insights. Thanks for sharing your question!

    Have a great day,

    Cedric.

    1
    Comment actions Permalink
  • Avatar
    jeff slater

    Hey Cedric,

    I appreciate the quick response and the tutorial you guys put together is great!

    Everything seems to work as expected in the IOS app but not in the Windows app.

    In the Windows Showpad app the asset viewer is invoked but the controls are different. In the header there is a left facing arrow that just puts me into other pieces of collateral.  The footer shows additional collateral and gives me the option to share, add to collection, add annotations and more. I'm still unable to close the PDF.

    Does application you built for the tutorial work on your end when you use it in the Windows App?

    Is it possible i'm missing something in the controls? 

    Thank you very much,

     

    0
    Comment actions Permalink
  • Avatar
    Sarah Shockey

    Hi Jeff,

    I'm jumping in to help on behalf of Cedric today! It looks like we were missing a modal parameter in the original code block of this section. Without this parameter, the link will jump directly to the asset and thus, returning will not bring you back to the Experience.

    We corrected this in the article (which you will now see if you click the above link) and have updated the .zip attachment to reflect this. Basically, you just have to add ?modal=1 before the closing tag (>) for the expected behavior to, well...behave!

    I hope this is helpful for you, and feel free to keep us posted on your coding journey. We appreciate your help!

    Cheers,

    Sarah

     

    0
    Comment actions Permalink
  • Avatar
    jeff slater

    Hey Sarah,

    You guys are incredible! Adding the parameter took care of my problem. I appreciate the patience and attention that this matter received.

    Thank you!


    0
    Comment actions Permalink

Please sign in to leave a comment.

Get the latest apps and email integrations

iOS App Store Google Play Store Microsoft Store